.::写在前面的话::.

打造FreeBSD桌面系统

来源:Yesky 作者:李建华 打包:gоld$n0kの

声明：本系列文档（文档内的文章除外）遵循GPL,任何个人以及任何组织不对此系列文档拥有版权。同时如本系列文档中的文章作者对此有异议请立即和我联系，本人将在尊重作者意愿的前提下对文档进行修改。在此感谢那些为BSD发展默默无闻的程序员们以及一切关心BSD成长的人们．

本文主要内容
第一部分 建立全中文桌面环境
一、安装和配置XFree86 | 二、安装GNOME图形桌面环境
三、GNOME的美化 | 五、安装Fcitx
四、Windows分区及光盘中文文件名显示
第二部分 FreeBSD下的实用软件
一、办公软件工具 | 二、图像处理软件
1．AbiWord──简单实用的字处理软件 | 1．图像处理工具——GIMP
2．星际译王──小巧玲珑的英汉词典 | 2．绘图工具——XPaint
3．Gnumeric──GNU的电子表格 | 3．图像浏览工具
4．ghex──十六进制编辑器 | 三、网络工具软件
5．Mozilla网页编辑器──主页制作 | 1．多功能即时通讯软件——Gaim
6．文件打包器──压缩/解压缩工具 | 2．GNU的FTP客户端工具——gFTP


第一部分 建立全中文桌面环境

    一、安装和配置XFree86

    要建立桌面环境，首先必须安装XFree86。在安装XFree86之前，需要决定安装哪个版本。XFree86 3.X是XFree86是XFree86开发的一个分支版本。它非常稳定，而且支持多种型号的显卡，但现在已经不对它进行更新了。XFree86 4.X是一个完全重新设计的分支，有很多新特性，比如更好地支持各种字体。所以目前本文以XFree86 4.X为例进行介绍，执行如下命令安装XFree86。

    #cd /usr/ports/x11/XFree86-4
    #make install clean

    安装XFree86后开始进行配置。在开始配置XFree86之前，必须知道本机系统的一些信息，包括：显示器的规格、显卡芯片类型和显存的大小。配置XFree86有如下几步：

    #XFree86 -configure

    在当前目录生成一个初始化配置文件XF86Config.new。

    #XFree86 -xf86config XF86Config.new

    测试配置文件是否正常，如果出现图形界面和X形的鼠标指针则说明配置成功，按“Ctrl+Alt+Backspace”组合键返回控制台。

    #ee XF86Config.new

    用ee编辑器打开XF86Config.new文件，配置显示器默认的分辨率和色深，这是通过“Screen”语句来定义的：

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    DefaultColorDepth 16
    SubSection "Display"
    Depth 16
    Modes "1024x768"
    EndSubSection
    EndSection

    在上面这行语句中，DefaultColorDepth关键字定义了显示器的默认色深。Modes关键字定义了给定色深下的屏幕分辨率。在上面的例子中，默认的色深是16位色，在这个颜色模式下，可以接受的分辨率是1024×768。

    最后，使用这个修改过的配置文件测试一下(运行命令XFree86 -xf86config XF86Config.new)。如果一切正常，那配置文件需要存放在XFree86能够找得到的地方，默认路径为/etc/X11/XF86Config。

    #cp XF86Config.new /etc/X11/XF86Config

    一旦配置文件被存放到了指定位置，XFree86的配置就大功告成了！


第二部分 安装GNOME图形桌面环境

二、安装GNOME图形桌面环境

    GNOME和KDE都是图形桌面环境，可以选择安装其中之一作为缺省图形桌面，也可以二都均安装，安装后可自己决定使用哪种桌面。GNOME是一个强大的图形桌面环境，它包括一个面板(用于开始应用程序和状态显示)、一个桌面(放置数据和应用程序)、多个窗口管理器(控制桌面外观及个人喜好设置)以及一套标准的桌面工作和应用程序。GNOME允许设置桌面外观和“感觉”，GNOME私人管理器能记住设置和当前应用程序，如图1所示。下面以GNOME为例介绍其安装及配置过程。

图1

    运行如下命令从ports安装GNOME。

    #cd /usr/ports/x11/gnome2
    #make install clean

    GNOME一旦被安装好，必须定义GNOME为默认的窗口管理器，这一步很简单，只需要在当前用户的家目录中建立一个名为.xinitrc的文件。

    #echo "/usr/X11R6/bin/gnome-session" >> ~/.xinitrc

    接着，键入startx命令，GNOME桌面环境就可以启动了。


第三部分 GNOME的美化

三、GNOME的美化

    本小节主要讨论FreeBSD基本的汉化、字体的模糊、Windows分区的中文显示、XMMS等GTK程序菜单及其他的中文显示，输入法fcitx的安装。

    1.Locale设定

    修改/etc/profile文件，在其中添加：

    LANG=zh_CN.eucCN
    LC_ALL=zh_CN.eucCN
    export LANG LC_ALL

    然后重新登录，键入startx命令进入GNOME环境，即可看到GNOME桌面环境已经完全中文化了，但中文字体不是很美观，这主要是因为中文字体文件的问题，下面我们就借用Windows中的“宋体”和“Tahoma”这两个字体来美化GNOME。

    2.设置字体

    (1)在/usr下建一个名为system的文件夹，然后再在里面建一个文件夹fonts，命令如下：

    #cd /usr
    #mkdir system
    #cd system
    #mkdir fonts

    (2)从Windows的fonts目录拷贝以下字体文件到/usr/system/fonts，要特别注意字体文件名的大小写，以下字体文件名都是小写：

simsun.ttf /如果是simsun.ttc改名成simsun.ttf
    tahomabd.ttf
    tahoma.ttf
    mingliu.ttf /加入繁体字库可以使繁体字更漂亮
(3)下载fonts.dir文件，并将其保存到/usr/system/fonts下，再将fonts.dir复制一份改名为fonts.scale。

    (4)下载fonts.conf文件，并将其保存到/usr/X11R6/etc/fonts/下覆盖原文件。

    (5)编辑/etc/X11/XF86Config文件，将其中Section "Files"和Section "Module"字段中的内容修改如下：

    Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    ModulePath "/usr/X11R6/lib/modules"
    FontPath "/usr/system/fonts"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
    EndSection

    Section "Module"
    Load "extmod"
    Load "glx"
    Load "dri"
    Load "dbe"
    Load "xtt"
    # Load "record"
    Load "xtrap"
    Load "speedo"
    # Load "type1"
    EndSection

    如果你使用的是滚轮鼠标，只需要将Section "InputDevice"字段中的内容替换为如下内容即可使鼠标滚轮生效。

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/sysmouse"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "yes"
    EndSection

    (6)下载 gtkrc.zh_CN文件，并将其保存到/usr/X11R6/share/themes/Default/下覆盖原文件。

    按照上述方法美化后，你可能会发现大部分X程序的字体都显示正常，但是一些基于GTK 1.x设计的程序的字体显示不正常，其实解决的方法很简单，只需要将/usr/X11R6/share/themes/Default/gtkrc.zh_CN文件复制到前用户的家目录中，并将其命名为.gtkrc.mine即可。

    (7)现在的桌面还不具备处理中文粗斜体的能力，为此，我们必须安装补丁程序(此补丁由linuxsir论坛的哈密瓜制作，按此下载)，将下载的补丁程序保存到/tmp，然后执行下列命令安装补丁。

    #tar xvfj FreebsdFontsHmg.tar.bz2
    #cd FreebsdFontsHmg
    #pkg_add -f *.*

     由于此补丁程序会自动改写/usr/X11R6/etc/fonts/fonts.conf文件中的内容，所以我们还需要重新下载fonts.conf文件并保存到/usr/X11R6/etc/fonts/目录将其覆盖。

    退出X桌面并重新进入使以上修改生效。在GNOME环境中点击“应用程序/桌面首选项/字体”，按图2所示进行设置。

图2

    启动Mozilla浏览器，依次打开“编辑/首选项/外观/字体”，将外观字体全部设置为Tahoma 9，如图3所示。

图3

    如果用户安装有XMMS，则会发现用XMMS播放MP3时不能正常显示中文标签，其实解决的方法很简单，只需要打开XMMS，按快捷键“Ctrl+P”打开“首选项”对话框，然后切换到“字体”选项卡，选中“使用字体集”和“使用X字体”复选框，并在其中的文本框中都输入“-adobe-helvetica-medium-r-normal-*-12-*-*-*-p-*-iso10646-1,-misc-simsun-medium-r-normal-*-12-*-*-*-c-*-gbk-0”即可，如图4所示。


第四部分 Windows分区及光盘的中文文件名显示

四、Windows分区及光盘的中文文件名显示

    当用户将Windows分区或光盘挂载到FreeBSD中后就会发现，其中的中文名全部显示为“?????”，使我们不能正常对中文文件进行操作，为了解决这一问题，可以安装gbfs，该ports位于/usr/ports/chinese/gbfs目录中，在安装该ports之前，请先对内核进行配置，注释掉其中的MSDOSFS、CD9660、CD9660_ROOT，即：

    #options MSDOS
    #options CD9660
    #options CD9660_ROOT

    然后重新编辑内核再安装gbfs，最后重新启动计算机使新内核生效，执行ls -w命令即可正常显示中文文件名，如图5所示。

图5

    五、安装Fcitx

    Fcitx（Free Chinese Input Toy for X）──小企鹅输入法的作者是Linuxsir论坛的Yuking，它是一个以GPL方式发布的、基于XIM的简体中文输入法(即原来的G五笔)，同时支持Linux和FreeBSD，目前最新版本为fcitx-2.0.1，此版本最新正式版，包括五笔、拼音(双拼和全拼)，执行以下命令安装Fcitx：

    #cd /usr/ports/chinese/fcitx
    #make install clean

    安装完成后，只需要将以下语句添加到当前用户家目录下的.xinitrc文件的开始位置，然后重新启动X即可。

    export XMODIFIERS=@im=fcitx
    fcitx&

    新的fcitx 2.0.1版本做的更漂亮了，首先是界面比以前更好看了，如图6所示。再就是~/.fcitx/config文件中的配置都是中文的，简单的按你的习惯更改就好了。还有就是在输入五笔时可以使用z开头来输入拼音，以及使用一个按键来切换中英文模式，这点与笔者喜欢的五笔加加非常类似。

图6

    到此为止，已经基本上完成了FreeBSD中文桌面环境的改造，在第二部分，笔者将介绍FreeBSD下常用的应用软件。


第五部分 办公软件工具

第六部分 办公软件工具(2)

4.ghex──十六进制编辑器

    大家一定对Windows环境下的UltraEdit编辑器印象很深刻吧？在FreeBSD上也有类似软件，GNOME环境环境中就提供了一个名为ghex编辑器，以十六进制显示和编辑文件。

    ghex的整个窗口被垂直分成两部分，左半边以十六进制字节显示指定文件的内容，右半边则对应地把每个字节以ASCII字符显示，无法显示的用“.”代替。当用户在任意一个窗口中移动光标时，另一个窗口中的光标也会相应移动。利用菜单命令用户就可以方便地进行拷贝、剪切、粘贴等操作了，如图10所示。

图10

    对查看、修改一些非文本的机器码文件，ghex是一个很好的工具。
    该port位于/usr/ports/editors/ghex2/目录中。

    5.Mozilla网页编辑器──主页制作

    Windows下的Dreamweaver、FrontPage给我们制作主页带来了很大的便利，同样，在FreeBSD下也有功能相似的软件代替，比如著名的Mozilla浏览器就自带了一个功能强大的网页编辑器，你可通过 Mozilla 网页编辑器创建你自己的网页，并在网上发布。你无需掌握 HTML 就可以使用这个网页编辑器；它用起来就象一个文字处软件一样简单易用。“工具栏”按钮用于添加列表、表格、图像、到其他页面的链接、颜色和字体样式。文档在网上的样式与你创建时的样式是一致的，并且可以很容易的与其他用户共享，不论他们使用什么类型的浏览器或哪一种具 HTML 功能的电子邮件程序，Mozilla网页编辑器的主界面如图11所示。

6.文件打包器──压缩/解压缩工具

    在Windows下最常见的压缩格式应该是Zip了，最常用的压缩工具应该是WinZIP和WinRAR。在FreeBSD下最常见的压缩包也是Zip，可是情况却有些不同──一般是先用tar（备份工具）将一系列文件打包成一个文件，然后再用gzip进行压缩。由于从网上下载的软件一般都是.tar.gz或者.tar.bz2格式的，因此我们在安装软件时一般都要用到tar、gzip或者bzip2，不知道大家是否用过，命令可是够长的，现在我们有了GNOME的文件打包器，一切都好办了。

    在GNOME下要压缩或解压缩文件是很方便的，对各种其支持的压缩文件，在GNOME的文件管理器（Nautilus）下只需要双击欲解压缩的文件，就会出现“文件打包器”窗口，在这个窗口中即可对压缩文件进行解压缩操作，如图12所示。

图12

    若要压缩文件，只需要选中欲压缩的文件，并单击鼠标右键，从弹出的快捷菜单中选择“添加到压缩文件”，此时会弹出一个对话框让用户选择压缩文件保存的路径和名称，如图13所示。需要注意的是必须输入带有后缀的文件名，一般的后缀名有.tar.gz、.tar.bz2和.zip，其中.tar.bz2的压缩率最大。


第六部分 图像处理软件

第七部分 图像处理软件

    FreeBSD下的图形图像处理软件比较丰富，比如图像处理工具GIMP、绘图工具XPaint、图像浏览工具电子眼ee，Compupic等等，这些工具都可从Ports中直接安装。

    1.图像处理工具——GIMP

    FreeBSD下的图像处理工具中，最著名的要数GIMP了。GIMP是GNU图像处理程序（GNU Image Manipulation Program）的缩写，它是一个完全免费的自由软件包，适用于对图像进行各种艺术处理。GIMP的功能非常强大，它可以作为一个简单的绘图程序来使用，也可以作为一个高质量的图像处理软件来使用，它还有图像格式转换等功能。GIMP具有高度可扩展能力，它支持带插件参数的高级脚本接口，对每项工作，无论是最简单的任务，还是复杂的图像处理过程，都可以很容易地用脚本来描述。由于其功能相当强大，因为GIMP被誉为FreeBSD下图像处理的法宝，是自由的PhotoShop。

     GIMP的界面要比PhotoShop简洁得多，启动时只有一个看起来和PhotoShop很相似的工具栏。只要当我们打开图像文件并用鼠标右键单击图像时才会弹出一系列的菜单选项，如图14所示。

图14

    GIMP主要有如下特点：
    ● 全套的绘图工具，包括笔刷、铅笔、喷枪等。
    ● 平板式的内存管理，能够处理的图像尺寸大小只受磁盘自由空间的限制。
    ● 支持各种常见的图形格式，包括gif、jpg、jpg、xpm、tiff、tga、mpeg、ps、pdf、pcx、bmp等，并能进行各种图形格式的相互转换。
    ● 过程数据库允许从外部程序调用内部的GIMP函数。
    ● 无限次的Undo/Redo（仅受磁盘空间的限制）。
    ● 支持旋转、缩放、裁剪及反转等变形工具。
    ● 具有多种选择工具，如矩形、椭圆、自由、模糊、曲线及智能。
    ● 插件功能允许用户任意增加文件格式及新的效果滤镜，并且网上有超过上百个免费的插件可供下载，这样一来就可以无限扩展GIMP的功能。

    另外，GIMP、对Web图片设计也有不错的支持，同时还提供了一个抓图工具——屏幕快照，效果非常不错，本文所有图片均由该工具截取。有关更多GIMP的功能介绍及使用方法，请参考由机械工业出版社发行的《GIMP权威指南》一书。

    2.绘图工具——XPaint

    XPaint是X11自带的一个彩色图像编辑工具，其功能与Windows中的“画笔”程序相似，支持编辑各种图像格式，包括PPM、XBM、BMP、jpg、TIFF等。XPaint的用户界面从功能上被分成两个区域，一个是工具区，用于选择当前绘画要进行的操作；另一个是绘图区，用于创建/修改图像。每个绘图窗口允许拥有自己的调色板和模式集，如图15所示。

图15

     XPaint对显示模式有所依赖，在存储图像的时候将会把图像调整为当前的显示模式（例如，在16位色环境中打开一幅32位真彩色的图像，重新存盘时会存储为16位色）。

    3.图像浏览工具

    与Windows一样，FreeBSD下的图像浏览工具也非常丰富，下面介绍几款比较常用的软件。

    (1)GNOME之眼

    “GNOME之眼”是一个在GNOME窗口环境下浏览图像文件的软件，它是随GNOME软件包一起分发的。当正确安装GNOME后，在GNOME的主菜单中就可以找到“GNOME”快捷方式。“GNOME之眼”可以浏览bmp、tif、gif、xpm等格式的图像文件，使用方法非常简单。用户可以选择一次装入多个文件，并可预图图像。“GNOME之眼”也支持对图像进行一些基本的编辑操作，比如色彩控制、放大、缩小和旋转等，软件主界面如图16所示。

图 16

    (2)GQview

    GQview也是一个在GNOME窗口环境下浏览图像的软件。其功能和使用方法与电子眼相似，只是更直观一些。GQview的用户界面左边是菜单条、工具栏、目录列表及图像文件列表，右边是图像浏览区，在图像文件列表中选择文件后，就可以在右边区域进行浏览了，这点倒和ACDSee相同，如图17所示。

图17

    GQview自身的图像编辑功能相对较弱，但它支持调用外部的图像处理软件，除了GIMP、电子眼等软件外，用户还可根据需要让GQview与其它图像编辑软件相关联。


第六部分 网络工具软件

第八部分 网络工具软件

    从FreeBSD诞生的那一天起，就注定了它的网络功能空前强大，使用FreeBSD的用户会发现在FreeBSD环境下上网效率会比Windows高很多，而且其安全性更是Windows所不能比拟的。FreeBSD环境下的网络工具数不胜数，下面介绍几款常用的网络工具。

    1.多功能即时通讯软件——Gaim

    采用开放系统架构设计的Gaim（GNU AIM）最初是作为AOL的即时通讯软件AIM的客户端进行设计的，它可以同时加载多个插件形式的即时通讯软件（Gaim本身并不具备通讯功能，而是通过插件来实现的）——不仅操作方法统一规范，而且还具有系统资源消耗小的优点，让“聊天狂人”们再不用手忙脚乱地在各个软件之间切来换去了，软件主界面如图18所示。

图18

    Gaim的安装版本中附带有很多流行的通讯插件，比如Yahoo通、MSN Messenger、ICQ、AIM、IRC等等。另人遗憾的是Gaim的安装版本中没有附带国内流行的QQ插件。其实Gaim的QQ插件其实早已问世，但是受到腾讯公司的打压，最新版本的QQ插件也只能支持到Gaim 0.64（目前最新版本为0.75），并且该插件只有for Linux版本，还没有公开源代码，所以即使要在FreeBSD上运行QQ For Gaim，也只能安装老版本的Gaim，而且还要使用Linux兼容模式运行，操作复杂且效率低下。如果一定要在FreeBSD上使用QQ，笔者推荐使用Perl OICQ，这是一个运行在命令行下字符界面的QQ，虽然界面简陋一些，但基本能够满足与QQ用户相互通讯的要求，关于该软件的更详细介绍请浏览http://perl-oicq.sourceforge.net/。

    Gaim的Port位于/usr/ports/net/gaim目录中，Perl OICQ的Port位于/usr/ports/chinese/oicq目录中。

    2.GNU的FTP客户端工具——gFTP

    gFTP是X Window下一个用Gtk开发的多线程FTP客户端工具。它与MS Windows环境中的CuteFTP等FTP工具极为类似，目前gFTP的最新版本是2.0.15支持并行下载、断点续传、传输任务队列、全目录下载等功能，其主界面如图19所示。

图19

    该Port位于/usr/ports/ftp/gftp目录中。如果想安装其它网络工具软件，可以到/usr/ports/net目录中查找。


第五部分 办公软件工具

第五部分 办公软件工具(1)

    近几年来，基于X环境下的办公软件得到迅猛发展，性能、种类直逼Windows平台上的办公软件，以前只有在Windows上才能办成的事，现在FreeBSD也能完成了。除了大家所熟悉的StarOffice、OpenOffice那样的大型办公套件外，FreeBSD上还有为数众多的小型办公软件，它们继承了UNIX的特性，往往只专注解决某一方面的问题，因此这些软件大都精悍实用。

    1.AbiWord──简单实用的字处理软件

    AbiWord是一款类似于微软Word程序的免费文字处理工具，它体积小却功能大非常适合处理文书、信件、报告、备忘录等常用办公文件，如图7所示。AbiWord 是开放源代码的软件，也是AbiSource办公套件的一部分。AbiWord的过人之处不仅在于免费提供了强大的文字处理功能，而且其开放源代码的自由构架模式可轻易把源程序编译成可在任何操作系统下运行的应用程序，任何语言版本的操作系统它都支持，同时，它还支持Word生成的DOC文件格式。

图7

    该port位于/usr/ports/editors/AbiWord2/目录中。

    2.星际译王──小巧玲珑的英汉词典

    星际译王的功能虽然没有金山词霸那样强大、词汇众多，但应付平时的工作需要还是足够了的。外语不太好的朋友，可多找它帮忙。在输入框中输入要查询的英文单词，在窗口的右侧就可看到翻译结果。而在在窗口的左侧，星际译王还列出了和输入的单词相关联的词，方便用户进一步查找。

    难能可贵的是，星际译王这个小软件竟然还具备了金山词霸所不具备的模糊查询功能，当用户记不清单词怎样拼写时，可用“？？”或“*”进行匹配查找，非常方便。如图8所示。

图8

    该port位于/usr/ports/chinese/stardict2/目录中。

    3.Gnumeric──GNU的电子表格

    Gnumeric是GNOME桌面环境的一个组成部分，是一个源代码开放的自由电子表格软件，其操作界面与Excel非常相似，如图9所示。与Excel一样，刚进入Gnumeric时，默认的空工作表也只有3个，如果需要更多的工作表，可以从“插入”菜单中选择“工作表”。

图9

    该port位于/usr/ports/math/gnumeric目录中。